MXroute Status
← Back

Early warning: Delayed outbound email

Degraded

Reported Mar 24, 2026 at 2:44 AM UTC · Resolved Mar 24, 2026 at 3:14 AM UTC · Duration: 29m

Affected Systems

zmta
SMTP

Outbound email delays just popped up again, repeat of this morning? Looking at it. We won’t let it be delayed by much.

Postmortem

Vultr had two outages today of a Dallas node that impacted our outbound server. Our outbound infrastructure has been painfully simple for a long time: One server with easy deployment of a spare in case of outage. In the coming weeks, this will finally be fully redundant and an outage will only cause email to go out through 1x /24 instead of causing outbound delays while the spare is deployed.

Updates

Resolved Mar 24, 2026 at 3:14 AM UTC

Delays are dropping on a fast path back to zero. It'll take a few minutes to reach zero, but everything is in order and as it should be, the remainder of this is simply processing delayed queues.

Investigating Mar 24, 2026 at 2:44 AM UTC

Outbound email delays just popped up again, repeat of this morning? Looking at it. We won’t let it be delayed by much.