MXroute Status
← Back

Outbound Delayed

Major Outage

Reported Mar 23, 2026 at 12:48 PM UTC · Resolved Mar 23, 2026 at 1:23 PM UTC · Duration: 35m

Affected Systems

zmta
SMTP

Currently experiencing delayed outbound email, investigating right now.

Updates

Resolved Mar 23, 2026 at 1:23 PM UTC

The cause of delayed outbound mail is resolved. It may take just a few minutes to push the waiting queue through.

Investigating Mar 23, 2026 at 12:48 PM UTC

Currently experiencing delayed outbound email, investigating right now.