MXroute Status
← Back

IMAP connectivity issues

Degraded

Reported Feb 27, 2026 at 7:47 PM UTC · Resolved Feb 27, 2026 at 8:26 PM UTC · Duration: 39m

Affected Systems

chocobo.mxrouting.net
IMAP

The Chocobo server saw intermittent IMAP connection failures today as one of these new-generation spammers found some really strange use case that managed to consume most available resources for the IMAP server. To put that in perspective, the limits configured for the IMAP server tend to house several thousand customers without issue, it only took 1 to break it with this use case. It's some kind of connection to warmup/cold email platforms (policy violations regardless). While the issue is resolved for now, we're continuing to monitor for any further use cases of this type and investigate what we can do to prevent this kind of distributed DOS against the IMAP server by actual customers. Why can't all threats just be external? Why can't people be normal?

Updates

Resolved Feb 27, 2026 at 8:26 PM UTC

Fix deployed to mitigate against this in the future.

Monitoring Feb 27, 2026 at 7:47 PM UTC

The Chocobo server saw intermittent IMAP connection failures today as one of these new-generation spammers found some really strange use case that managed to consume most available resources for the IMAP server. To put that in perspective, the limits configured for the IMAP server tend to house several thousand customers without issue, it only took 1 to break it with this use case. It's some kind of connection to warmup/cold email platforms (policy violations regardless). While the issue is resolved for now, we're continuing to monitor for any further use cases of this type and investigate what we can do to prevent this kind of distributed DOS against the IMAP server by actual customers. Why can't all threats just be external? Why can't people be normal?