MXroute Status
← Back

Small percentage of email seeing delays

Degraded

Reported Aug 25, 2026 at 2:36 PM UTC · Resolved Aug 25, 2026 at 2:53 PM UTC · Duration: 16m

Affected Systems

eagle.mxlogin.com
SMTP
pixel.mxrouting.net
SMTP
taylor.mxrouting.net
SMTP
sunfire.mxrouting.net
SMTP
blizzard.mxrouting.net
SMTP
longhorn.mxrouting.net
SMTP
safari.mxrouting.net
SMTP
lucy.mxrouting.net
SMTP
arrow.mxrouting.net
SMTP
echo.mxrouting.net
SMTP
london.mxroute.com
SMTP
shadow.mxrouting.net
SMTP
moose.mxrouting.net
SMTP
tuesday.mxrouting.net
SMTP
monday.mxrouting.net
SMTP
wednesday.mxrouting.net
SMTP
redbull.mxrouting.net
SMTP
witcher.mxrouting.net
SMTP
heracles.mxrouting.net
SMTP
everest.mxrouting.net
SMTP
glacier.mxrouting.net
SMTP
fusion.mxrouting.net
SMTP
chocobo.mxrouting.net
SMTP
ocean.mxroute.com
SMTP
aus.mxroute.com
SMTP
banshee.mxlogin.com
SMTP
friday.mxlogin.com
SMTP

A small percentage of emails have been seeing minor delays this morning. It seems to be a bit of a moving target, so we're trying to figure out a root cause. I opted to select every server just as a precaution, but it never seems to occur to more than 2-3 at a time.

Updates

Resolved Aug 25, 2026 at 2:53 PM UTC

Resolved for now, but we'll still keep working on more improvements throughout the day to try to prevent a recurring issue.

Investigating Aug 25, 2026 at 2:36 PM UTC

A small percentage of emails have been seeing minor delays this morning. It seems to be a bit of a moving target, so we're trying to figure out a root cause.