MXroute Status
← Back

Hubspot temporarily blocked on wednesday.mxrouting.net server

Degraded

Reported Aug 24, 2026 at 9:42 PM UTC · Resolved Aug 25, 2026 at 2:58 AM UTC · Duration: 5h 16m

Affected Systems

wednesday.mxrouting.net
SMTP

An account farmer who created a number of Tavily accounts that I now assume to be in the 10s of thousands, and attempted to forward each one to multiple remote recipients, triggered a fleet-wide emergency when Tavily rapidly sent out a newsletter to all users. The end result of this emergency, the only part customers need to be aware of, is that Hubspot is temporarily blocked on the Wednesday server as they are currently performing the equivalent of a DDOS attack against the SMTP server. The user has been terminated for causing this event, in direct violation of our policies, and we are monitoring to see when we can unblock Hubspot.

Postmortem

Resolved.

Updates

Resolved Aug 25, 2026 at 2:58 AM UTC

This incident has been resolved.

Monitoring Aug 24, 2026 at 9:42 PM UTC

An account farmer who created a number of Tavily accounts that I now assume to be in the 10s of thousands, and attempted to forward each one to multiple remote recipients, triggered a fleet-wide emergency when Tavily rapidly sent out a newsletter to all users. The end result of this emergency, the only part customers need to be aware of, is that Hubspot is temporarily blocked on the Wednesday server as they are currently performing the equivalent of a DDOS attack against the SMTP server. The user has been terminated for causing this event, in direct violation of our policies, and we are monitoring to see when we can unblock Hubspot.