MXroute Status
← Back

Acadia Issue

Major Outage

Reported Aug 20, 2026 at 5:15 AM UTC · Resolved Aug 20, 2026 at 5:18 AM UTC · Duration: 3m

Affected Systems

acadia.mxroute.com
IMAP SMTP POP3 Webmail

The Acadia server was experiencing high iowait, and is being rebooted. If that doesn't help, we'll have to reach out to the server provider.

Updates

Resolved Aug 20, 2026 at 5:18 AM UTC

This incident has been resolved.

Investigating Aug 20, 2026 at 5:15 AM UTC

The Acadia server was experiencing high iowait, and is being rebooted. If that doesn't help, we'll have to reach out to the server provider.