Crossbox on fusion.mxrouting.net is being fun
Partial OutageReported Aug 3, 2026 at 9:38 AM UTC · Resolved Aug 4, 2026 at 9:41 PM UTC · Duration: 1d 12h 2m
Affected Systems
fusion.mxrouting.net
Webmail
Crossbox is not reliable on the fusion.mxrouting.net server right now. Please use other webmail options such as webmail.mxroute.com, Roundcube, or your own email clients.
Updates
Resolved
Aug 4, 2026 at 9:41 PM UTC
This incident has been resolved.
Identified
Aug 3, 2026 at 9:38 AM UTC
Crossbox is not reliable on the fusion.mxrouting.net server right now. Please use other webmail options such as webmail.mxroute.com, Roundcube, or your own email clients.