MXroute Status
← Back

DDOS on wednesday.mxrouting.net

Major Outage

Reported Jul 17, 2026 at 10:37 PM UTC · Resolved Jul 17, 2026 at 11:43 PM UTC · Duration: 1h 6m

Affected Systems

wednesday.mxrouting.net
IMAP SMTP POP3 Webmail

The wednesday.mxrouting.net server is experiencing a large inbound DDOS attack. Working on mitigation.

Updates

Resolved Jul 17, 2026 at 11:43 PM UTC

This incident has been resolved.

Investigating Jul 17, 2026 at 10:37 PM UTC

The wednesday.mxrouting.net server is experiencing a large inbound DDOS attack. Working on mitigation.