MXroute Status
← Back

Crossbox on witcher.mxrouting.net down

Partial Outage

Reported Jul 17, 2026 at 8:41 PM UTC

Affected Systems

witcher.mxrouting.net
Webmail
mail.mxlogin.com
Webmail

Crossbox is causing severe problems on the witcher.mxrouting.net server. To keep things stable, it has been disabled. Users on the witcher server will need to use webmail.mxroute.com, or any other mail client of their choosing. The alternative is worse. We will follow up with this a bit later after gathering more information about the event.

Updates

Identified Jul 19, 2026 at 1:12 AM UTC

The Crossbox devs have reached out and they have been very willing to cooperate on this. We're not trying to throw Crossbox under the bus here. They've been great and worked with us at every turn. Our concerns lie a bit deeper than just mitigating the largest factor of this event, and those concerns are not a negative judgement against anyone. The concerns are about how we can offer the best reliability for the services that we are focused on. We will update this when we've landed on a decision for how we want to move forward with this.

Identified Jul 18, 2026 at 4:16 AM UTC

The path forward on this is unclear, and it's precisely because we do not develop the software that is malfunctioning. If you find yourself tapping your finger on your desk saying "When is this webmail going to be back up" my advice would be to make alternate plans. If bringing it back up means taking the server down, it's a no-brainer, it stays down. That's what users on the server were reporting, an outage caused by this webmail capping 15+ CPU cores and maxing out disk IO by endlessly looping a quota check against a 32GB email account, only to instantly restart the quota check every single time it ended. So what are we going to do? We need a little more time to formulate a plan, because telling you part of a plan just makes people open tickets asking why part 1 doesn't include X, Y, or Z. So better to keep any plan silent until it's finalized.

Identified Jul 17, 2026 at 8:41 PM UTC

Crossbox is causing severe problems on the witcher.mxrouting.net server. To keep things stable, it has been disabled. Users on the witcher server will need to use webmail.mxroute.com, or any other mail client of their choosing. The alternative is worse. We will follow up with this a bit later after gathering more information about the event.