MXroute Status
← Back

Upgrading webmail.mxroute.com

Maintenance

Reported Jul 9, 2026 at 11:33 PM UTC · Resolved Jul 10, 2026 at 12:13 AM UTC · Duration: 39m

Affected Systems

webmail.mxroute.com
Webmail

The webmail.mxroute.com instance will appear as down for a very short moment while we upgrade it.

Updates

Resolved Jul 10, 2026 at 12:13 AM UTC

This incident has been resolved.

Identified Jul 9, 2026 at 11:33 PM UTC

The webmail.mxroute.com instance will appear as down for a very short moment while we upgrade it.