Issue with Taylor server
DegradedReported Jul 7, 2026 at 7:21 PM UTC · Resolved Jul 8, 2026 at 3:47 PM UTC · Duration: 20h 25m
Affected Systems
taylor.mxrouting.net
IMAP
SMTP
POP3
Webmail
You no doubt noticed issues with the Taylor server. They should be clearing up now, not yet ready to write out a conclusion. Just know that the root cause is settled, the rest still needs investigation.
Updates
Resolved
Jul 8, 2026 at 3:47 PM UTC
This incident has been resolved.
Investigating
Jul 7, 2026 at 7:21 PM UTC
You no doubt noticed issues with the Taylor server. They should be clearing up now, not yet ready to write out a conclusion. Just know that the root cause is settled, the rest still needs investigation.