MXroute Status
← Back

heracles.mxrouting.net web server

Degraded

Reported Jun 22, 2026 at 8:16 PM UTC · Resolved Jun 22, 2026 at 8:41 PM UTC · Duration: 24m

Affected Systems

heracles.mxrouting.net
Webmail

We are performing emergency maintenance to fix the reliability issues with webmail on heracles.mxrouteinc.net. Please feel free to use webmail.mxroute.com, mail.mlxogin.com, or your own email client as heracles.mxrouting.net/webmail may be intermittently unavailable for a moment.

Updates

Resolved Jun 22, 2026 at 8:41 PM UTC

This incident has been resolved.

Identified Jun 22, 2026 at 8:16 PM UTC

We are performing emergency maintenance to fix the reliability issues with webmail on heracles.mxrouteinc.net. Please feel free to use webmail.mxroute.com, mail.mlxogin.com, or your own email client as heracles.mxrouting.net/webmail may be intermittently unavailable for a moment.