MXroute Status
← Back

fusion.mxrouting.net web server

Degraded

Reported Jun 22, 2026 at 6:53 PM UTC · Resolved Jun 22, 2026 at 8:15 PM UTC · Duration: 1h 22m

Affected Systems

fusion.mxrouting.net
Webmail

Performing emergency maintenance on the web server on fusion.mxrouting.net. Please use webmail.mxroute.com, mail.mxlogin.com, or your own email client during this time as fusion.mxrouting.net/webmail may be briefly unavailable.

Updates

Resolved Jun 22, 2026 at 8:15 PM UTC

This incident has been resolved.

Identified Jun 22, 2026 at 6:53 PM UTC

Performing emergency maintenance on the web server on fusion.mxrouting.net. Please use webmail.mxroute.com, mail.mxlogin.com, or your own email client during this time as fusion.mxrouting.net/webmail may be briefly unavailable.