MXroute Status
← Back

Web server on fusion.mxrouting.net

Degraded

Reported Jun 22, 2026 at 2:40 AM UTC · Resolved Jun 22, 2026 at 2:49 AM UTC · Duration: 8m

Affected Systems

fusion.mxrouting.net
Webmail

The web server on fusion.mxrouting.net is giving us some trouble. Feel free to use webmail.mxroute.com, mail.mxlogin.com, or your own email client during this time as fusion.mxrouting.net/webmail is not responding at the moment.

Updates

Resolved Jun 22, 2026 at 2:49 AM UTC

It's resolved, for now. But at this point, we have to talk about the per-server Roundcube instances going away. That's going to impact a few features, but we can't change how DirectAdmin works overnight.

Investigating Jun 22, 2026 at 2:40 AM UTC

The web server on fusion.mxrouting.net is giving us some trouble. Feel free to use webmail.mxroute.com, mail.mxlogin.com, or your own email client during this time as fusion.mxrouting.net/webmail is not responding at the moment.