MXroute Status
← Back

London server emergency maintenance

Maintenance

Reported May 31, 2026 at 7:32 PM UTC · Resolved May 31, 2026 at 8:25 PM UTC · Duration: 53m

Affected Systems

london.mxroute.com
IMAP SMTP POP3 Webmail

The london.mxroute.com server (198 users) is being taken down for emergency maintenance. We're going to reseat a memory stick that has been working hard since 2019, as that was identified as the cause of a crash earlier today.

Updates

Resolved May 31, 2026 at 8:25 PM UTC

Memory stick replaced, all is well.

Identified May 31, 2026 at 7:32 PM UTC

The london.mxroute.com server (198 users) is being taken down for emergency maintenance. We're going to reseat a memory stick that has been working hard since 2019, as that was identified as the cause of a crash earlier today.