MXroute Status
← Back

heracles.mxrouting.net, everest.mxrouting.net packet loss

Degraded

Reported May 30, 2026 at 4:52 PM UTC · Resolved May 30, 2026 at 5:43 PM UTC · Duration: 50m

Affected Systems

heracles.mxrouting.net
IMAP SMTP POP3 Webmail
everest.mxrouting.net
IMAP SMTP POP3 Webmail

The heracles.mxrouting.net server is experiencing high packet loss over ICMP on the Hetzner network. Hetzner is investigating, as slowly as humanly possible. In our tests, TCP connections have still been working fine, so we're not inclined to call this an outage.

Postmortem

We saw 100% ping packet loss, but in our tests 100% success in actual connection to services. We had some scattered reports about an outage, but couldn't prove any. Ping outages trip monitors, but they don't indicate actual service failure. Hetzner would not treat it as a network issue and refused to investigate. We see no action item here right now. The monkeywrench: Heracles couldn't connect to our outbound filter for a while and had to withhold all outbound mail for just a bit, which does suggest a network issue, but if the people running the network refuse to look at it and everything looks fine now, don't know what else to do but call it done.

Updates

Resolved May 30, 2026 at 5:43 PM UTC

Correction. Hetzner is not investigating and refuses to do so. Reports have slowed and while ICMP is still showing upwards of 100% failure in tests, there is clearly nothing that we can do about that. Considering as resolved as it can be. A big thank you to Hetzner for deciding our next server location for us: Not there.

Investigating May 30, 2026 at 4:52 PM UTC

The heracles.mxrouting.net server is experiencing high packet loss on the Hetzner network. Hetzner is investigating, as slowly as humanly possible.