Support experiencing degraded performance

Blizzard Server Outage

Resolved
Operational
Started about 1 year ago Lasted 5 minutes

Affected

DirectAdmin Panel
IMAP
SMTP
Webmail
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    The Blizzard server is experiencing an issue. We are currently investigating this incident.