Support experiencing degraded performance

Billing System Maintenance

Completed
Scheduled for April 07, 2023 at 9:00 PM – 9:45 PM

Affects

Billing Panel
Updates
  • Completed
    April 07, 2023 at 9:45 PM
    Completed
    April 07, 2023 at 9:45 PM

    Maintenance has completed successfully.

  • In progress
    April 07, 2023 at 9:00 PM
    In progress
    April 07, 2023 at 9:00 PM

    Maintenance is now in progress

  • Planned
    April 07, 2023 at 9:00 PM
    Planned
    April 07, 2023 at 9:00 PM

    We are planning for a scheduled maintenance during that time.