Support experiencing degraded performance

Support Wait Times

Resolved
Degraded performance
Started over 1 year ago Lasted 5 months

Affected

Support
Updates
  • Resolved
    Resolved

    For the vast majority this has never been a problem, it isn't fair to keep this on the status page when it impacts such a small percentage of overall support tickets. Consider this a mild realigning of philosophy for the status page, which is something we're always iterating on.

  • Identified
    Identified

    Wait times for support escalations are not within an optimal time range. This is a temporary issue and we will keep the status page updated as they begin to level out.