London Webmail Outage

Major Incident London
5 minutes

Update

Resolved

Apache restarted, appears to be doing okay.

Feb 18th, 2020 23:31 CST
Issue

London webmail reporting down. Investigating.

Feb 18th, 2020 23:26 CST