Ghost SMTP Down

Major Incident Ghost
38 minutes

Update

Resolved

Online.

Jan 31th, 2020 10:52 CST
Issue

We’re having to disable SMTP on Ghost temporarily to deal with a unique and severe spam issue.

Jan 31th, 2020 10:15 CST