Billing portal disabled

Major Incident Billing Portal
45 minutes

Update

Resolved

Billing portal re-enabled.

Dec 25th, 2019 21:12 CST
Issue

Due to endless registrations for purpose of harassment, the billing portal is offline. Please note that past due services are not suspended until 3 months past due.

Dec 25th, 2019 20:29 CST