Website outage

Major Incident Website
49 minutes

Update

Resolved

Website back online

Dec 25th, 2019 21:12 CST
Issue

Front website down due to DDOS.

Dec 25th, 2019 20:24 CST