"550 Administrative prohibition" on Echo

Major Incident Echo
39 minutes

Update

Resolved

While this is resolved for now, a post-mortem will be sent out to customers on the server tomorrow detailing plans to prevent this from happening again, and any new information gained in the investigation of the event.

May 20th, 2020 at 22:34 CDT
Update

Mitigated, inbound restored. Not certain event is over, still working on it.

May 20th, 2020 at 22:19 CDT
Investigating

Temporarily blocked inbound email so that email sent during this time will retry delivery later, rather than be rejected by the 550 error. Temporarily mitigation while we continue.

May 20th, 2020 at 22:11 CDT
Issue

Customers reporting error “550 Administrative prohibition” on inbound email on Echo server. Working with devs to resolve previously reported issue seems to be causing this, working to mitigate/restore.

May 20th, 2020 at 21:56 CDT