Support experiencing degraded performance

Crossbox (mail.mxlogin.com) packet loss

Resolved
Degraded performance
Started 4 months ago Lasted 7 minutes

Affected

Webmail
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    There is currently a high amount of packet loss on the Hetzner network leading to our Crossbox instance (mail.mxlogin.com). This may cause timeouts when using that email client. If you need a webmail client immediately and this is impacting you, try using webmail.mxroute.com. We have other webmail clients, that's just a personal favorite.