Support experiencing degraded performance

Comcast outage

Resolved
Operational
Started 5 months ago Lasted about 2 hours

Affected

SMTP
Updates
  • Resolved
    Resolved

    Comcast has resolved this issue.

  • Identified
    Identified

    Comcast has identified the problem and claims it will be clearing up soon.

  • Investigating
    Investigating

    Customers are unable to send emails to comcast.net due to an outage of Comcast's mail servers. We are following this as it progresses.