Support experiencing degraded performance

Witcher server

Resolved
Operational
Started 5 months ago Lasted 11 minutes

Affected

DirectAdmin Panel
IMAP
SMTP
Webmail
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.