MXroute - Lucy Email Queues Backed Up – Incident details
All systems operational
Lucy Email Queues Backed Up
Resolved
Degraded performance
Started about 2 years agoLasted 3 minutes
Affected
SMTP
Degraded performance from 8:21 PM to 8:24 PM
Updates
Resolved
Resolved
This incident has been resolved.
Investigating
Investigating
Users on the lucy.mxrouting.net server are seeing email stuck in queue, not being delivered (inbound or outbound). We are currently investigating this incident.