Support experiencing degraded performance

Crossbox (mail.mxlogin.com) issues

Resolved
Operational
Started about 1 year ago Lasted 1 day

Affected

Webmail
Updates
  • Resolved
    Resolved

    Still monitoring for this, but considering it resolved.

  • Monitoring
    Monitoring

    We’ve had two outages of Crossbox in the last ~24 hours, and we expect it to be a recurring problem for just a bit longer. We’ll aim to minimize the outages and reduce them to hopefully no more than a 3 minute issue each time. A software update will fix this, but isn’t yet ready.