All systems operational

Resolved
wednesday.mxrouting.net slow outbound

Started
January 27, 2024 at 10:42 PM
Status
Resolved after about 3 hours

Impact

Operational
Affected
SMTP
  • Resolved
    Resolved

    Considering this resolved but still have automation watching for it and automatically mitigating it, just in case.

  • Investigating
    Investigating

    We are investigating an issue that has resulted in intermittently delayed outbound email for users on the wednesday.mxrouting.net server today. This is not an outage, and it's likely something no user has even noticed, so this status may be up for a long period today while we observe it's behavior over several hours.