All systems operational

Resolved
Partial/intermittent iCloud Outage

Started
January 16, 2024 at 10:09 PM
Status
Resolved after about 19 hours

Impact

Operational
Affected
SMTP
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Update

    The iCloud outage has not been fixed. We are unable to deliver more than half of emails sent to iCloud users, and we have done our due diligence to confirm that it is not related to us. Even our fallback services are unable to deliver the emails.

  • Identified
    Identified

    Users at iCloud are not currently capable of instantly receiving all email sent to them. Some email sent to them will arrive instantly as expected, others could be delayed for 1-2 hours. We’ve been noticing this for several hours today and expected it to clear up faster than it has.

    This is not an MXroute issue, but it does impact MXroute users. iCloud users are likely unaware of this issue.