All systems operational

Resolved
Longhorn Server

Started
August 14, 2023 at 7:44 PM
Status
Resolved after 20 minutes

Impact

Operational
Affected
Billing Panel
IMAP
SMTP
Webmail
  • Resolved

    This incident has been resolved.

  • Investigating

    We are currently investigating this incident. No email will be lost due to their event.