MXroute - Crossbox for wednesday.mxrouting.net users – Incident details
All systems operational
Crossbox for wednesday.mxrouting.net users
Resolved
Operational
Started about 2 years agoLasted about 20 hours
Affected
Webmail
Operational from 2:04 AM to 10:03 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
Crossbox (mail.mxlogin.com) is currently down for users on the wednesday.mxrouting.net server. Please use https://wednesday.mxrouting.net/webmail or your own email clients until we have it running again.