MXroute - Outbound mail delays – Incident details

All systems operational

Outbound mail delays

Resolved
Degraded performance
Started 16 days agoLasted about 1 hour

Affected

SMTP

Degraded performance from 7:36 PM to 8:35 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    A small percentage of outbound mail from our platform is seeing delays higher than normal. This is being caused by packet loss to our cloud provider's location. We're working to mitigate this delay as much as possible while working to resolve the issue. We expect very few customers (1-5 range) to notice this.