MXroute - Outbound email delivery delays – Incident details

All systems operational

Outbound email delivery delays

Resolved
Operational
Started about 1 month agoLasted 11 minutes

Affected

SMTP

Operational from 4:25 PM to 4:35 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Postmortem:

    In certain events this config block caused exim to give an empty HELO to postfix:

    helo_data = ${if eq{$sender_address_domain}{}\

    {${lookup{${lc:${domain:$h_from:}}}lsearch,ret=key{/etc/virtual/domainowners}{$value}}}\

    {${if exists{/etc/virtual/helo_data}{${lookup{$sending_ip_address}iplsearch{/etc/virtual/helo_data}{$value}{$primary_hostname}}}{$primary_hostname}}}\

    }

    That config block has been updated:

    helo_data = ${if exists{/etc/virtual/helo_data}{${lookup{$sending_ip_address}iplsearch{/etc/virtual/helo_data}{$value}{$primary_hostname}}}{$primary_hostname}}

  • Identified
    Identified

    We're seeing some intermittent outbound email delivery delays due to a strange issue with postfix. Currently investigating the problem a bit deeper with an increased log level to see if we can shake loose some more details.