MXroute - Spam filters on Arrow server – Incident details

All systems operational

Spam filters on Arrow server

Resolved
Operational
Started about 1 year agoLasted about 18 hours

Affected

SMTP

Operational from 10:57 PM to 5:19 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Spam filters on the arrow.mxrouting.net server are not performing as desired after upgrading to the new system. More spam is coming in than is desirable. We are working on this.