MXroute - Outbound delivery delay – Incident details

Support experiencing degraded performance

Outbound delivery delay

Resolved
Partial outage 30 %
Started 2 months agoLasted about 1 hour

Affected

SMTP

Partial outage from 12:23 PM to 1:13 PM, Degraded performance from 1:13 PM to 1:27 PM

Updates
  • Resolved
    Resolved

    Mail flow fully restored. It will take a bit longer to push all of the email that was queued during this, but it is flowing.

    What happened: Our cloud provider rebooted the node without notice. Our interfaces did not come up as intended, monitoring system did not trip because BGP didn't actually go down, ZoneMTA couldn't create outbound connections. Connections from the same /24 to the same /24 no longer worked over port 2525.

    What we did: Bring interfaces up, get email flowing again. Changed postfix bind address on filter server to cloud-provided IP to compensate for failure to connect over 2525 from/to the same /24 (as this "appears" to be outside of our ability to impact). Adjusted DNS for filter006.mxroute.com for Received header reverse DNS checks. Flushed mail queue. Changed monitoring system to ping the /24 that sends mail rather than just monitor it's BGP session.

  • Monitoring
    Monitoring

    Outbound mail flow is restored, but it is taking a bit of time to get all of the queued emails out.

  • Identified
    Identified

    Outbound delivery is currently delayed on our network, working to resolve quickly.