MXroute - Crossbox (mail.mxlogin.com) on glacier.mxrouting.net server acting up – Incident details

All systems operational

Crossbox (mail.mxlogin.com) on glacier.mxrouting.net server acting up

Resolved
Degraded performance
Started about 1 month agoLasted 2 days

Affected

Webmail

Degraded performance from 10:26 PM to 7:24 AM, Operational from 7:24 AM to 1:47 PM, Degraded performance from 1:47 PM to 9:41 PM

Updates
  • Resolved
    Resolved

    This has been resolved for most of the day, we just wanted to give it time to be sure.

  • Identified
    Identified

    It is happening again. You can expect Crossbox to be down on the glacier.mxrouting.net server until the developers are able to address it, because this is not something we can fix. You should use an alternate webmail today if you can, like webmail.mxroute.com.

  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We are still waiting on a response from the developers of Crossbox. It is not within our ability to fix this while ensuring that no unnecessary problems are created from the fix.

  • Investigating
    Investigating

    Redis appears to be failing on Crossbox (mail.mxlogin.com) for the glacier.mxrouting.net server. We are investigating. Feel free to use https://webmail.mxroute.com or any other webmail, or email client, during this time.