MXroute - Possible Crossbox Outage – Incident details

All systems operational

Possible Crossbox Outage

Resolved
Operational
Started about 1 month agoLasted about 9 hours

Affected

Webmail

Operational from 8:28 AM to 5:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are having problems paying our vendor, Crossbox (mail.mxlogin.com) because they no longer take PayPal, and no US credit card company is allowing us to make payments to their country. We are working to find a way to get money to them, but until that time there is a possibility that Crossbox may display a license error. If that is the case, please use any of our other webmail clients or your own email client. Crossbox is but one of our webmail options, we’re also quite proud of webmail.mxroute.com as it’s a very cozy Roundcube setup.