MXroute - Billing system unable to reach mail servers – Incident details
All systems operational
Billing system unable to reach mail servers
Resolved
Degraded performance
Started 15 days agoLasted 40 minutes
Affected
Billing Panel
Degraded performance from 10:30 PM to 11:10 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
Our billing system at accounts.mxroute.com is currently unable to reach any of our US-based mail servers, including the one that it uses to send out welcome emails, invoices, etc. We're working on it.