MXroute - Emails to/from Outlook/Hotmail/Office365 – Incident details

All systems operational

Emails to/from Outlook/Hotmail/Office365

Resolved
Operational
Started 11 days agoLasted 39 minutes

Affected

SMTP

Operational from 9:31 PM to 10:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Microsoft is currently experiencing a large scale outage. Emails sent to them are being delayed by their servers, emails sent from them are likely experiencing similar. We are monitoring the reports of and keeping an eye on our queues to see when they are able to resolve this.