MXroute - Crossbox (mail.mxlogin.com) for users on wednesday.mxrouting.net server – Incident details

All systems operational

Crossbox (mail.mxlogin.com) for users on wednesday.mxrouting.net server

Resolved
Operational
Started 2 months agoLasted about 11 hours

Affected

Webmail

Operational from 6:52 AM to 5:56 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    At least 2 users have reported a license expired error when using Crossbox (mail.mxlogin.com) with the wednesday.mxrouting.net server as their home server. This is not within our control, we have a ticket open with the developer. In the meantime, feel free to use webmail.mxroute.com, wednesday.mxrouting.net/webmail, or any other available webmail or non-webmail related client. This is not considered to be a service outage as this is merely one of many available webmail clients, and it does not relate to the actual email service.