MXroute - Crossbox down for users on wednesday.mxrouting.net server – Incident details

All systems operational

Crossbox down for users on wednesday.mxrouting.net server

Resolved
Operational
Started about 1 month agoLasted 1 day

Affected

Webmail

Operational from 4:16 AM to 7:08 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    The application reports that the license is expired for this server. It isn't. We've done everything we can, it's in the hands of their developers as of right now. You can use any other email client or webmail client in the meantime, webmail.mxroute.com is a popular choice.