MXroute - Outbound Email Delays – Incident details

All systems operational

Outbound Email Delays

Resolved
Degraded performance
Started about 1 month agoLasted 22 minutes

Affected

SMTP

Degraded performance from 1:08 PM to 1:26 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Emergency network maintenance in the location of our outbound relays currently causing delays for outbound mail.

  • Investigating
    Investigating
    We are currently investigating this incident.